You need to be Payday Loans UK Why would you

Update php5-* without portupgrade “php5-*”

The following solution update php5-* without portupgrade “php5-*”

For example if you lose db with information about installed ports

There is a simple solution to deinstal\reinstall\install extention php5

I suppose you’ve already installed (updated) php5.
create script:

#touch php5_update.sh
#vim php5_update.sh

and past this:

#!/bin/sh
grep -oE '=[a-z]+' /usr/local/etc/php/extensions.ini | \
sed -E 's/^./php5-/' | \
while read pkg;
do {
cd /usr/ports;
cd `make quicksearch name="^$pkg-" | \
grep -oE '/usr/ports/.+$'` && make install;
} done;

Don’t forget

#chmod +x php5_update.sh

Make shure that your /usr/local/etc/php/extensions.ini have information about needed extentions and start:

#./php5_update.sh

You can change script for you aims, For example you can change make reinstall to make deinstal or make install if you want delete of install needed extentions.

PS: I advise use portupgrade “php5-*” if it possible in your case.

With this method I’ve solved problem with php when all php scripts works with big delays (about 60sec) even command php -r ‘echo “test string \n”;’

[Tue Sep 01 16:19:21 2009] [warn] FastCGI: (dynamic) server “/xxx/www.cgi/php-fcgi.sh” started (pid 89108)
[Tue Sep 01 16:19:25 2009] [warn] FastCGI: (dynamic) server “/xxx/www.cgi/php-fcgi.sh” started (pid 89113)
[Tue Sep 01 16:19:28 2009] [warn] FastCGI: (dynamic) server “/xxx/www.cgi/php-fcgi.sh” started (pid 89118)
[Tue Sep 01 16:19:31 2009] [warn] FastCGI: (dynamic) server “/xxx/www.cgi/php-fcgi.sh” started (pid 89124)
[Tue Sep 01 16:19:34 2009] [warn] FastCGI: (dynamic) server “/xxx/www.cgi/php-fcgi.sh” started (pid 89129)
[Tue Sep 01 16:19:37 2009] [warn] FastCGI: (dynamic) server “/xxx/www.cgi/php-fcgi.sh” started (pid 89135)
[Tue Sep 01 16:19:40 2009] [warn] FastCGI: (dynamic) server “/xxx/www.cgi/php-fcgi.sh” started (pid 89140)
[Tue Sep 01 16:19:43 2009] [warn] FastCGI: (dynamic) server “/xxx/www.cgi/php-fcgi.sh” started (pid 89145)
[Tue Sep 01 16:19:46 2009] [warn] FastCGI: (dynamic) server “/xxx/www.cgi/php-fcgi.sh” started (pid 89150)
[Tue Sep 01 16:19:49 2009] [warn] FastCGI: scheduled the start of the last (dynamic) server “/xxx/www.cgi/php-fcgi.sh” process: reached dynamicMaxClassProcs (10)
[Tue Sep 01 16:19:49 2009] [warn] FastCGI: (dynamic) server “/xxx/www.cgi/php-fcgi.sh” started (pid 89155)

portupgrade “php5-*” in my case didn’t helped me. My php-extentions was separately installed at the different times. I was been needing deinstall all php5-extention. This script good solve it.

Leave a Reply