You need to be Payday Loans UK Why would you

Update to php 5.3.6 problem (autoconf: required version 2.68 not found)

Was updating php on FreeBSD to php 5.3.6
lang/php5 updated correctly but when I tried update php5-extensions – it cause problems. I also tried article
portupgrade for certain module also didn’t work (php5-mcrypt, for example):
howtobsd# portupgrade php5-mcrypt
[Updating the pkgdb
in /var/db/pkg ... - 951 packages found (-1 +0) (...) done]
---> Upgrading 'php5-mcrypt-5.3.3_2' to 'php5-mcrypt-5.3.6' (security/php5-mcrypt)
---> Building '/usr/ports/security/php5-mcrypt'
===> Cleaning for php5-mcrypt-5.3.6
===> Vulnerability check disabled, database not found
===> License check disabled, port has not defined LICENSE
===> Extracting for php5-mcrypt-5.3.6
=> SHA256 Checksum OK for php-5.3.6.tar.bz2.
===> Patching for php5-mcrypt-5.3.6
===> php5-mcrypt-5.3.6 depends on file: /usr/local/bin/phpize - found
===> php5-mcrypt-5.3.6 depends on file: /usr/local/bin/autoconf-2.68 - found
===> php5-mcrypt-5.3.6 depends on shared library: mcrypt.8 - found
===> php5-mcrypt-5.3.6 depends on shared library: ltdl.7 - found
===> PHPizing for php5-mcrypt-5.3.6
Configuring for:
PHP Api Version: 20090626
Zend Module Api No: 20090626
Zend Extension Api No: 220090626
autoconf: required version 2.68 not found
*** Error code 1
Stop in /usr/ports/security/php5-mcrypt.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20110417-89058-19avmgv-0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=php5-mcrypt-5.3.3_2 UPGRADE_PORT_VER=5.3.3_2 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
! security/php5-mcrypt (php5-mcrypt-5.3.3_2) (unknown build error)

As you can see autoconf 2.68 required:

howtobsd# portupgrade autoconf

But also you need update autoconf-wrapper:

howtobsd# portupgrade autoconf-wrapper

after that it updated.

One Response to “Update to php 5.3.6 problem (autoconf: required version 2.68 not found)”

  1. thanx mate !

Leave a Reply